This article describes minimum client requirements for the Barium Live that can be accessed using a compliant web browser/and or a REST API client.


Specific requirements

Requirements for web browser clients (using the web-based user interface)

NOTE: Other browsers or newer versions of the listed browsers will probably work, but full functionality cannot be guaranteed.


  • A modern web browser. Google Chrome, Mozilla Firefox, Apple Safari latest versions or Microsoft Internet Explorer 9 or 11.
  • JavaScript enabled in the web browser (this is a standard setting in all web browsers).
  • Cookies must be allowed according to the standard settings of your web browser (cookies are only used to enable functionality on the Barium Live service such as logging in).
  • No limitations to normal web browsing (may apply to certain users in organisations)
  • A PDF viewer (such as Adobe reader or Foxit reader) with support for viewing PDF files in the web browser.
  • Adobe Flash Player (optional for previewing documents)


NOTE! Certain server-based operating systems such as Windows Server or Citrix may limit normal web browsing. Barium Live may not work as intended in this case.


Specific requirements for the Barium Live BPMN Modeler 1.0

Modeling processes in the Barium Live BPMN Modeler 1.0 has specific requirements.


  • Microsoft Internet Explorer 9 or 11 on Microsoft Windows.
  • Internet Explorer 9 needs to run in 32-bit mode.
  • Microsoft .Net Framework 2.0 SP1 or later.
  • Barium Process Modeling Support (installed by end users following instructions available when logged on to Barium Live or distributed as an MSI package using a software distribution tool).
  • The website URL https://live.barium.se must be added to the Trusted Sites security zone in the web browser.
  • HTTP/HTTPS traffic to the https://live.barium.se website must be allowed.


Specific requirements for the Barium Live BPMN Modeler 2.0

Please read the article Technical Requirements - Barium Live BPMN Modeler 2.0


Requirements for REST API clients

Support for the HTTP and HTTPS protocol and JSON data format is required to be able to use the REST API. Software vendors/developers need an API-key, username and password to be able to integrate and perform tests towards the service. This will be provided by Barium AB. Please don’t hesitate to contact Barium at live@barium.se if you have further questions.


  • Support for the HTTP and HTTPS protocol and JSON data format is required to be able to use the REST API.
  • All REST API calls must be in compliance with the Barium Live REST API specification found on the Barium Live Help Center


As an alternative to updating old/slow versions of Internet Explorer, you can install Google Chrome Frame. Google Chrome Frame is an add-on for Internet Explorer 6 or later that enhances the performance and user experience without the need to upgrade Internet Explorer. Read more on http://www.google.com/chromeframe.


Requirements for the mobile client interface

Barium Live offers the possibility for process applications to be activated for mobile clients. Users that log onto Barium Live using a mobile internet browser on a smart phone can see and perform tasks in an interface adapted for mobile devices. The mobile interface must be activated and configured for process applications that wish to offer smart phone support.


The mobile client interface is to offer a broad support for the vast majority of all smartphone, tablet, and e-reader platforms. The user experience will differ depending on which device is used to access Barium Live and it is important to look at the technical requirements when planning on offering mobile support for users in a process application.


To use the mobile interface make sure that you use a device that fullfills the following requirements:


  • Is a modern smart phone (with support for HTML 5)
  • Has a 3G internet connection or better


For a complete list of which mobile devices are support, visit the Detailed Technical Requirements - Mobile Client Interface